Apache Geode中文社区

 找回密码
 立即注册

扫一扫,访问微社区

搜索
查看: 6983|回复: 0

Pivotal Gemfire9.4 发布了

[复制链接]

32

主题

111

帖子

793

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
793
发表于 2018-4-11 16:02:31 | 显示全部楼层 |阅读模式
今天,Pivotal Gemfire开发部门发布了基于Apache Geode1.5内核的商用版:Pivotal Gemfire 9.4 。这个版本非常适合并强烈推荐给现有的GemFire versions 8.2.3-8.2.9, 9.0.*, 9.1.*, 9.2.* or 9.3.*的用户。

这个版本里包含了下列用户可见的改善:
- 在OQL查询的WHERE子句中增加了对于算术运算符(mod,%,+, - ,/和*)的支持
- 增加了一个新的API来destroy GatewayReceiver
- 增加了一个新的Geode示例演示了的expiration功能
- 关于客户端安全性的Geode示例现在使用SSL

新增和增强的gfsh命令:
- 尝试将旧版本的gfsh连接到新版本locator现在不支持了
- 您可以在初始化一个Declarable对象(如CacheListener)时通过gfsh提供参数。
- 有一个新的gfsh命令来创建JNDI绑定。
- 您可以为create和alter region gfsh命令设置custom expiry。 gfsh describe region命令列出了custom expiry设置。
- gfsh connect命令现在推断HTTP或HTTPS的正确连接机制。

此版本中还有一些不直接对用户可见的内部增强功能:
- 改进eviction算法的性能,使其更加一致。
- 当一个事务destroy了一个已经被eviction的region的一个region entry时,该entry现在可被视为垃圾收集对象了。
- 备份的代码现在更加模块化,将来有望成为插件。

本发行版中有一些旧功能已被deprecated,eprecated功能将在未来的主要版本中删除:
- Region.registerInterest方法的ALL_KEYS或List参数已被deprecated。 Region接口API已得到增强,以包含专门针对所有密钥和密钥列表的register interest方法。
- gfsh create region命令的--template-region选项已被deprecated。

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Apache Geode中文社区  

GMT+8, 2019-10-23 19:24 , Processed in 0.082961 second(s), 25 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表